Turn signal light

Got a Tech Question? Know something about BMWs?

Moderator: JimVonBaden

Turn signal light

Postby colberr » Mon May 12, 2003 5:53 pm

Right rear turn signal went out on 1998 R1200C. Replaced bulb and still not working. Is this something normal for R1200C? Do I need to replace unit bulb goes into? :?:
colberr
 

Postby Anton » Sat May 24, 2003 8:45 pm

I don't know of anything specific to the R1200. If it happened to me I'd do the following as basic troubleshooting:

1) check voltage at the wires that plug into the turn signal housing. I've had these connections become loose; lightly squeeze the female connector with some pliers to improve the contact if you find it loose. If you get no voltage at all during signalling, proceed to...

2) trace the wiring back and see if there are any other connections in the harness. For example, my PD has a plug under the seat that connects all of the lights at the rear of the bike, and this plug can get corroded. If you have such a plug, disconnect and reconnect it. Still nothing? ...

3) Unplug and then reconnect the flasher unit. If my 'fiche is accurate, your signal relay is the same as is used on basically every other Oilhead and K1200 BMW made, so you might be able to find someone to swap with you and verify if it's good or not.
Anton Largiader
The Muffin Man
http://vamotorrad.com
User avatar
Anton
Board Wizard
 
Posts: 1289
Joined: Sat May 24, 2003 8:34 pm
Location: Charlottesville, VA

Postby owls1 » Mon Jun 09, 2003 9:57 am

Just about all the connectors on a M/C are subject to corrosion - becomes problem especially on a fuel injected motor as time goes by. I strongly recommend that as soon as possible on a new or old bike, you search out all electrical plug connectors. Unplug, clean with electrical contact cleaner if necessary, blow dry, then apply small amount of dielectric grease to the female connectors. ("Tune-up grease" available in small tubes at your local auto parts store) Do not fill the connector body, squeeze a small amount into each female terminal. Plug and unplug the connector a couple of times and move to the next. The grease will not interrupt the connection and will keep out moisture, dirt, and corrosion. If you do this for your headlight connector, you will never have to struggle to get it off when replacing bulbs again!

For ground connection lugs that are fastened to the frame with screws, get a tube of conductive grease - the kind that electricians use for aluminum lead in cables to homes from the pole (available at most electrical supply stores) - clean the contact area on the frame and apply some of this grease to the terminals, screw, and contact area - refasten. Keep this kind of grease away from multi-pin connectors as it will short them out!

Only caution is to use both sparingly and if your machine is equipped with an oxygen sensor, DO NOT USE ANY GREASE ON THE OXYGEN SENSOR SIGNAL CONNECTION (single wire). This signal is in the 0v - 0.8v region and the dielectric grease will interfere with it.
owls1
 


Return to Tech

Who is online

Users browsing this forum: No registered users and 7 guests

cron