ABS fault '09 R1200GS

Got a Tech Question? Know something about BMWs?

Moderator: JimVonBaden

ABS fault '09 R1200GS

Postby dcgsrider » Sat Jul 13, 2019 9:23 am

Key-on, engine start. "Brake failure" light comes on solid and stays that way for the duration of the ride--it never flashes, as in the "normal" diagnostic procedure. It's sensing a fault in the system, even before wheels are rolling, which I understand is when the system checks the wheel sensors.

I guess I need a GS-911 to pull the codes. Odd thing is I've only ridden it a few times since changing the gear oil in the final drive--and then the fault code displayed. Could be just a coincidence, but I don't like coincidences...
Paul Wilson
Arlington, Va.
2009 R1200GS "Franz" Namibia Orange
IBA# 12143
KI4PW
User avatar
dcgsrider
Board Guru
 
Posts: 347
Joined: Mon Aug 30, 2010 9:55 am
Location: Arlington, Va.

Re: ABS fault '09 R1200GS

Postby thanatos1224 » Sun Jul 14, 2019 6:53 pm

The club has an old version of the GS-911 :-)
David & Carol
Just finding an excuse to ride
User avatar
thanatos1224
Board Guru
 
Posts: 311
Joined: Sun Jan 14, 2018 11:14 am

Re: ABS fault '09 R1200GS

Postby eap » Tue Jul 16, 2019 3:14 pm

Also, take a look at your sensor rings on the wheels to see if they're physically gunked up or even bent.
eap
Chesapeake Bay Watershed http://www.chesapeakebay.net
"Over the Mountains Of the Moon, Down the Valley of the Shadow, Ride, boldly ride, E.A.Poe
14 R1200GS LC
01 R1150GS (100K smiles)
81 R80G/S (~50k smiles)
IBA # 60680
User avatar
eap
Board Wizard
 
Posts: 1757
Joined: Sat Aug 07, 2004 10:13 am
Location: Gaithersburg, MD

Re: ABS fault '09 R1200GS

Postby bdimon » Tue Nov 12, 2019 9:27 pm

dcgsrider wrote:I guess I need a GS-911 to pull the codes. Odd thing is I've only ridden it a few times since changing the gear oil in the final drive--and then the fault code displayed. Could be just a coincidence, but I don't like coincidences...


I have the GS-911. When do you want to meet up to get it?
Bruce Dimon
2005 R1200RT
Webmaster & Media Chair :D
User avatar
bdimon
Board Guru
 
Posts: 870
Joined: Sun Feb 19, 2012 5:22 pm
Location: Fairfax, VA

Re: ABS fault '09 R1200GS

Postby dcgsrider » Sun Nov 24, 2019 1:41 pm

bdimon wrote:
dcgsrider wrote:I guess I need a GS-911 to pull the codes. Odd thing is I've only ridden it a few times since changing the gear oil in the final drive--and then the fault code displayed. Could be just a coincidence, but I don't like coincidences...


I have the GS-911. When do you want to meet up to get it?


Thanks, Bruce. I pulled the rear wheel and the reason for the fault became instantly apparent. The wire to the rear ABS sensor had come loose, rubbed on the rear wheel flange, and was eaten completely through. The replacement part was ~$150.
Paul Wilson
Arlington, Va.
2009 R1200GS "Franz" Namibia Orange
IBA# 12143
KI4PW
User avatar
dcgsrider
Board Guru
 
Posts: 347
Joined: Mon Aug 30, 2010 9:55 am
Location: Arlington, Va.


Return to Tech

Who is online

Users browsing this forum: Majestic-12 [Bot] and 3 guests